8 minute read

Introduction

Network

Network란 그저 connection이 가능한 device들의 연결이다. 이때, device는 host(computer, phone) 또는 다른 connecting device (switch, modem) 다 될 수 있다.

Network의 종류를 적용되는 지역에 따라 나눌 수 있다.

  1. Local Area Network LAN
    • 한 건물이나 campus처럼 제한된 영역에서의 network이다.

    • Host들간의 연결을 수행한다

    • High speed

    • low cost

    • Privately owned

    joowan1108

  2. Wide Area Network WAN
    • Wider span (town, state, country)

    • Connecting devices 간의 연결을 수행한다

    • Low speed

    • High cost

    • Communication companies owned

    Wide Area Network에는 두 종류가 있다.

    Point to Point WAN

    오직 두 connecting device만 연결

    joowan1108

    Switched WAN

    여러 Point to Point WAN의 조합

    joowan1108

이때, 두 개 이상의 network가 연결된 것을 internet이라고 한다.

Network에서 Data 전송: Switching

internet에서는 하나의 switch가 최소 두 개 이상의 device을 연결한다. 이때, switch란 한 device에서 다른 device에 정보를 전달해주는 역할을 하는 device이다. 이 전달 과정을 Switching이라고 한다.

Switching에는 두 가지 종류가 있다.

  1. Circuit Switching
    • Dedicated (물리적인) connection : Circuit
    • Connection이 항상 가능함
    • Switch는 그저 이 connection을 활성화 / 비활성화 시키는 역할을 한다.
  2. Packet Switching
    • Data의 단위가 packet
    • Circuit switching처럼 연속적인 연결이 아니라 독립적인 data packets의 형태로 data를 주고 받음
    • Packet switched network의 router는 전송해야 할 packet을 담는 router queue을 갖고 있음

Internet은 packet switched network의 예시로 Internet을 사용하기 위해서는 ISP (Internet Service Provider)와 물리적으로 연결되어 있어야 한다. 이 연결은 보통 point-to-point WAN으로 수행된다.

Protocol Layering

Protocol이란 sender, receiver, 그리고 모든 중간의 devices들이 통신을 하기 위해서 지켜야 할 규칙이라고 이해하면 된다.

Protocol Layering가 지켜야하는 원리는 두 가지이다.

  1. 각 layer는 서로 반대되는 task을 둘 다 할 수 있어야 한다.

    Each layer is able to perform two opposite tasks, one in each direction

    ex) Source에서의 Encapsulation vs Destination에서의 Decapsulation

    $\rightarrow$ Encapsulation은 정보를 추가, decapsulation은 정보 분해라고 생각하자

    이때, router는 두 개 이상의 link으로 연결되어 있기 때문에 한 방향의 정보 연결에서도 decapsulation과 encapsulation을 둘 다 한다.

    ex) Source에서의 Multiplexing vs Destination에서의 Demultiplexing

    $\rightarrow$ Multiplexing은 lower layer에게 encapsulation 결과를 전달, demultiplexing은 higher layer에게 decapsulation 결과를 전달

    이 과정은 one at a time으로 이뤄진다

  2. 동일한 layer에서 다루는 object는 동일해야 한다.

    Two objects under each layer at both sites should be identical

    joowan1108

Protocol Layering의 예시로 Internet에서 사용되는 TCP/IP Protocol이 있다.

TCP: Transmission Control Protocol

IP: Internet Protocol

joowan1108

한 통신 시스템에서 5개의 devices들 (Computer A, link 1의 switch, router, link 2의 switch, Computer B)이 연결되어 있다고 해보자

joowan1108

각 device는 자기가 참여하는 layer들까지의 protocol을 사용한다. 예를 들어, router는 오직 data가 오고 갈 경로만 알아내는 역할을 하기 때문에 Network layer까지만 필요로 한다.

이때, logical connection이란 동일한 level의 TCP/IP model 간의 연결이라고 한다. Physical layer와 Data link layer는 그저 local한 정보를 전달하는 역할을 하기 때문에 logical connection을 갖지 않는다 반대로 Application, Transport, Network layer는 logical connection을 갖는다.

따라서, Application, Transport, Network layer는 internet domain duty을 수행하고 Physical layer와 Data link layer는 link (physical) domain duty을 수행한다고 보면 된다.

joowan1108

TCP/IP Layer Protocol에서 각 Layer의 역할

  1. Application Layer
    • 통신이 되기 위해서는 한 process가 다른 process에게 요청을 해야 한다.
  2. Transport Layer
    • Application layer가 사용할 수 있는 service을 제공하는 역할 담당
    • 두 process 간의 통신 (Process to process) 담당
  3. Network Layer
    • Source computer와 destination computer 간의 연결을 담당한다
    • Host to host connection을 수행한다
    • 정보가 어떤 data link을 통해 이동을 해야 할 지 결정한다
  4. Data Link Layer
    • Link을 통해 datagram을 전송하는 역할
  5. Physical Layer
    • Link 내에서 frame 단위로 bits을 나르는 역할

TCP/IP Layer Protocol의 Addressing

어떤 통신이든 두 party 간의 연결은 두 주소값이 필요하다. 따라서 TCP/IP Layer Protocol에서는 총 8개의 주소가 필요하다. (Physical layer는 address 자체를 사용하지 않는다.)

joowan1108

OSI Model vs TCP/IP Layer Protocol

OSI(Open System Interconnection)는 ISO(International Organization for Standardization)에서 세운 Protocol Layering이다.

joowan1108

OSI는 7 layer로 되어있지만 TCP/IP는 5 layer로 되어있는데 그 이유는 OSI의 Presentation과 Session layer가 TCP/IP에서는 하나의 Application layer로 합쳐져 있기 때문이다.

OSI는 이론적 참조 모델인 반편 TCP/IP는 실제로 사용되는 실무적인 protocol이다.

Internet History

Early 1990’s

ARPAnet decommissioned

1991 : NSF lifts restrictions on commercial use of NSFnet : Cerf and Kahn-architecture for interconnection networks

Web Hypertext, HTML, HTTP 1994 : Mosaic, later Netscape

Late 1990’s

commercialization of the web

Late 1990’s – 2000’s

More killer apps : instant messaging, P2P file sharing

Network security to forefront

Backbone link running at Gbps

Standards and Administration

Internet standard란 Internet을 사용하는 사람들이 따라야 할 전체적인 구조/규칙이다. TCP/IP protocol도 이 Internet standard을 따른다.

Internet standard의 규칙이 되기 위해서는 다음 단계를 거친다

  1. Internet draft: 아이디어 초안
  2. RFC(Request for Comment): Internet draft가 인터넷 관리 기구 (Internet authorities)에서 허락을 받게 되면 RFC가 된다.
  3. RFC의 등급(Maturity levels)이 결정된다.

joowan1108

  • Proposed Standard

    안정적이고 잘 이해되는 RFC

    주로 Test을 거치는 단계이다

  • Draft Standard

    Proposed Standard가 최소 두 번의 성공적인 implementation을 거치게 된다면 Draft Standard가 된다.

    after at least two successful independent and interoperable implementations

  • Internet Standard

    Draft standard에서 Implementation의 demonstration이 수행된다면 Internet Standard가 된다.

    after demonstrations of successful implementation

  • Historic

    역사적으로 보았을 때, 뛰어난 경우

    모든 RFC 등급은 historic이 될 수 있다.

  • Experimental

    Internet에는 영향을 주지 않지만 실험적인 경우

  • Informational

    Internet과 관련된 많은 정보를 가지고 있는 경우

    제조사 (vendor)처럼 non-Internet organization 사람이 작성한다

RFC Requirement Levels

  • Required

    모든 Internet system이 구현해야 할 정도로 중요한 경우

  • Elective

    필수 아니고 추천도 안되는 경우

    하지만 사용은 가능한 경우

  • Limited Use

    특정 상황에서만 사용되어야 하는 경우

  • Not Recommended

    추천하지 않고 사용되면 안되는 경우

Administration

ISOC (Internet Society)

  • The ISOC is an international, nonprofit organization formed in 1992 to provide support for the Internet standards process

IAB (Internet Architecture Board)

  • The IAB is the technical advisor to the ISOC

IETF (Internet Engineering Task Force)

  • The IETF is a forum of working groups managed by the IESG (Internet Engineering Steering Group)

  • IETF is responsible for identifying operational problems and proposing solutions to these problem

IRTF (Internet Research Task Force)

  • The IRTF is a forum of working groups managed by the IRSG (Internet Research Steering Group

IANA (Internet Assigned Numbers Authority)

  • The IANA, supported by the U.S. government, was responsible for the management of Internet domain names and addresses until October 1998

ICANN (Internet Corporation for Assigned Names and Numbers)

  • The ICANN, a private nonprofit corporation managed by an international board, assumed IANA operations

NIC (Network Information Center)

  • The NIC is responsible for collecting and distributing information about TCP/IP protocols

Pratice Problems

Transport Protocol 종류

  • UDP based : DNS, DHCP, NTP, SNMP

  • TCP based : HTTP, FTP, Telnet, SSL, SMTP

Different Transport layer Standard Protocols in TCP/IP Model

TCP (RFC 793), MPTCP (RFC 6824), UDP (RFC 768), SCTP (RFC 4960), DCCP (RFC 4340).

TCP와 UDP 차이점

joowan1108

LAN과 WAN의 차이점

LAN : A high speed (~1 Gbps), low cost and easy to setup computer network covering small geographic area. (Example - Campus LAN)

WAN : A less speed (~ 150 Mpbs), high cost & complex computer network covering broad areas. (Example - Internet)

OSI Model

The Open Systems Interconnection (OSI) Model is a reference model that characterizes the way applications should communicate over a network.

TCP/IP vs OSI

The OSI model PRESCRIBES the steps needed to transfer data over a network. It represents an Ideal world. Obvious difference in the number of layers.

The OSI model “prescribes” and TCP/IP model “describes”. TCP/IP model exhibits practical prototype

Which statements are True/False about Circuit Switched Networks and Packet Switched Networks

A. Packets being sent over the Internet can be arbitrarily large F

B. All packets will follow the same fastest path through the network F

C. Packets can be received out of order without the message being corrupted T

D. ISPs are able to control information being sent over the internet T

During a video call, the screen freezes for 2–3 seconds and then continues normally. Which explanation bestmatches packet-switched Internet behavior?

A. The network reserved a dedicated circuit, so freezing cannot occur X

B. Packets may be delayed in router queues; late packets cause temporary freezing O

C. Packet always switching guarantees a constant rate of transmission X

D. Packet switching sends data as one continuous stream without packets X

In TCP/IP, a packet at the third layer carries data belonging to the ________ layer and the header belonging to the _________ layer.

A. third; third X

B. third; fourth X

C. fourth; third O

D. fourth; fourth X

Devices including hubs, cables, and repeaters function at the ___ layer of the TCP/IP model, whereas routers operate at the ___ layer.

A. Data-link layer, Network layer X

B. Transport layer, Application layer X

C. Application layer, Transport layer X

D. Physical layer, Network layer O

Complete the table by filling the full form of mentioned abbreviation of the technologies and whether they use Circuit Switching (CS) and Packet Switching (PS).

joowan1108

Fill in the blanks: History of the Internet

A. The Internet was originally developed as a project by the U.S. Department of Defense called _____

$\rightarrow$ ARPA Net

B. The system of unique addresses used to identify devices on the Internet is called _____

$\rightarrow$ Internet Protocol

C. The first-ever _____ was sent in 1971 by Ray Tomlinson.

$\rightarrow$ Email

D. WWW stands for _____ which was invented by Tim Berners-Lee in 1989.

$\rightarrow$ World wide web

E. The popular search engine _____ was created in 1998 and revolutionized the way people find information online.

$\rightarrow$ Google

F. The introduction of the _____ in 2007 by Apple transformed how people access the Internet, leading to the rise of mobile computing.

$\rightarrow$ SIRI

Besides ARPANET, which of the following is/are developed or funded by the Defense Advanced Research Projects Agency (DARPA)?

A. Siri O

B. Global Positioning System (GPS) O

C. Very-Large-Scale Integration (VLSI) O

D. Atlas by Boston Dynamics O

Before modern browsers like Google Chrome and Mozilla Firefox, the very first web browser was created as part of the invention of the World Wide Web. Which company invented the first web browser?

A. Microsoft

B. Netscape

C. CERN $\rightarrow$ O

D. IBM

Pick the correct standardization body for the mentioned tasks.

A. The _____ is the main global body that allocates and manages radio frequency spectrum and satellite orbits

$\rightarrow$ ITU

B. _____ allocates frequency for 3G/4G/5G between cellular network operators in South Korea like SK Telecom, KT, and LG U+

$\rightarrow$ RRA

C. In South Korea, the organization responsible for developing and promoting ICT standards, including telecommunications, AI, and IoT, is _____

$\rightarrow$ TTA

D. The __ is a research-driven organization in South Korea responsible for advancing wireless communication technologies, including 6G

$\rightarrow$ ETRI

E. The __ develops global standards for technologies like Wi-Fi and Ethernet

$\rightarrow$ IEEE

Possible options

  • MSIT (Ministry of Science and ICT)
  • IETF (Internet Engineering Task Force)
  • ITU (International Telecommunication Union)
  • RRA (National Radio Research Agency)
  • TTA (Telecommunications Technology Association)
  • ETRI (Electronics and Telecommunications Research Institute)
  • ITU (International Telecommunication Union)
  • IEEE (Institute of Electrical and Electronics Engineers)